Update PowerShell 7.0 & & 7.1 To Protect Your Azure Reso…

https://gbhackers.com/update-powershell-7-0-7-1/

Bundle Name
Vulnerable Versions
Protect Versions

System.Text.Encodings.Web
4.0.0– 4.5.0
4.5.1

Any type of following.NET 5,. WEB Core, or.NET Framework-based application that makes use of the System.Text.Encodings.Web strategy with an at risk variant.

You can follow us on Linkedin, Twitter, Facebook for everyday Cybersecurity and also hacking information updates.

System.Text.Encodings.Web
4.6.0-4.7.1.
4.7.2.

According to a Microsoft record “The susceptible package is System.Text.Encodings.Web. Updating your package as well as redeploying your application needs to suffice to settle this susceptability.”

Microsoft supplied a safety and security upgrade for Azure individuals versus an essential Remote code implementation insect that affects.NET Core at PowerShell Version 7.0 & & & 7.1, and also the insect makes it possible for cyberpunks to access to your Azure sources from another location.

The Vulnerability can be tracked as CVE-2021-24112 that is influenced by the.NET 5.0,. NET Core 3.1, and.NET Core 2.1 also remember that Windows PowerShell 5.1 isn’t impacted by this problem.

PowerShell is a scripting language that is created on the.NET Common Language Runtime (CLR) as well as is developed with the features to run cross-platform consists of on Windows, Linux, as well as macOS.

Considering that there is no workaround reduction, Microsoft very suggested updating from PowerShell Version 7.0 to 7.0.6 & & & Version 7.1 to 7.1.3. You can download and install the new variant of PowerShell below.

System.Text.Encodings.Web.
5.0.0.
5.0.1.